Service Disruption while accessing PitneyAnalytics
Incident Report for Pitney Bowes
Resolved
The issue has been resolved, and Services are back to normal now
Posted Nov 14, 2024 - 13:14 EST
Investigating
We are observing issue while accessing PitneyAnalytics
Teams are actively working towards resolution.
Posted Nov 14, 2024 - 10:15 EST
This incident affected: PitneyAnalytics (PitneyAnalytics USA, PitneyAnalytics Canada).