FedRAMP application is experiencing connectivity issues

Incident Report for Pitney Bowes

Resolved

The issue is resolved and application is fully functional.
Posted Jun 26, 2024 - 02:39 EDT

Investigating

The FedRAMP region was experiencing an issue preventing clients to login and access the SP360 application.
Posted Jun 26, 2024 - 02:14 EDT
This incident affected: FedRAMP (PitneyShip & PitneyShip Pro, PitneyTrack, ParcelPoint, PitneyAnalytics).