UPS Rating and Shipping Services Disruption

Incident Report for Pitney Bowes

Resolved

The issue is resolved, and services are back to normal now.
Posted Sep 23, 2024 - 16:34 EDT

Investigating

UPS Rating and Shipping Services Disruption
Posted Sep 23, 2024 - 14:48 EDT
This incident affected: Carriers (UPS).