FedEx Service Disruption Observed for RateShipment.
Incident Report for Pitney Bowes
Resolved
The issue has been resolved and Services are back to normal now.
Posted Nov 15, 2024 - 07:13 EST
Investigating
Failures are being observed for RateShipment calls with FedEx carrier.
Teams are actively working with FedEx towards resolution.
Posted Nov 15, 2024 - 07:04 EST
This incident affected: Carriers (FedEX).