Service Disruption observed in PitneyAnalytics for US and Canada Region

Incident Report for Pitney Bowes

Resolved

The issue has been resolved, and all services are back to normal.
Posted Mar 19, 2025 - 15:02 EDT

Update

Shipping360 PitneyAnalytics application is now experiencing a full outage since 2:25 PM EST. The root cause is Snowflake AWS having an outage at this time. Pitney Bowes Technical Team continue to work through this, and we will update as soon as possible.
Posted Mar 19, 2025 - 14:55 EDT

Update

Shipping360 PitneyAnalytics application is now experiencing a full outage since 2:25 PM EST. The root cause is Snowflake AWS having an outage at this time. Pitney Bowes Technical Team continue to work through this, and we will update as soon as possible.
Posted Mar 19, 2025 - 14:50 EDT

Update

We are currently experiencing slowness with our PitneyAnalytics APIs for USA region, but PitneyAnalytics continues to be operational. We will send you an update as soon as possible.
Posted Mar 19, 2025 - 13:12 EDT

Investigating

We are currently experiencing slowness with our PitneyAnalytics APIs for USA region.
Our Outage Response Team is investigating to determine the full scope of the outage and will be working to restore the operation of the APIs. We will send you an update as quickly as possible.
Posted Mar 19, 2025 - 11:53 EDT
This incident affected: PitneyAnalytics (PitneyAnalytics USA, PitneyAnalytics Canada).