Service Disruption observed for Shipping for Canada region.

Incident Report for Pitney Bowes

Resolved

The issue has been resolved and all services are back to normal.
Posted Apr 06, 2026 - 11:23 EDT

Investigating

Failures are being observed for Shipping for Canada region.
Pitney Bowes Technical Teams are actively working on this and we will update as we make progress.
Posted Apr 06, 2026 - 10:10 EDT
This incident affected: Shipping (PitneyShip Pro Canada).