Fedex Service Disruption Observed for RateShipment.

Incident Report for Pitney Bowes

Resolved

The issue has been resolved and all services are back to normal.
Posted May 14, 2026 - 17:12 EDT

Investigating

Failures are being observed for Shipping for USA region.
Pitney Bowes Technical Teams are actively working on this and we will update as we make progress.
Posted May 14, 2026 - 13:45 EDT
This incident affected: Shipping (PitneyShip & PitneyShip Pro USA, PitneyShip Enterprise USA, ShipAccel USA).