Partial Service Disruption observed for SP360 PitneyAnalytics for US, Canada and FedRAMP region.

Incident Report for Pitney Bowes

Update

The issue has been resolved for FedRAMP(GovCloud) and Canada region. Investigation for the US region is currently in progress, and we will keep you posted with further updates.
Posted Jan 30, 2026 - 13:04 EST

Investigating

We are currently experiencing technical issues with our SP360 PitneyAnalytics for US, Canada and FedRAMP(GovCloud) region.
Our Outage Response Team is investigating to determine the full scope of the outage and will be working to restore the operation of the APIs. We will send you an update as quickly as possible.
Posted Jan 30, 2026 - 12:03 EST
This incident affects: PitneyAnalytics (PitneyAnalytics USA, PitneyAnalytics Canada) and FedRAMP (PitneyAnalytics).