Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 29, 2025 - 20:00 EDT
Scheduled
The USPS has scheduled maintenance on the Product Tracking Reporting (PTR) system. During the maintenance window, the USPS will not be processing manifest files or providing scan events for tracking numbers. Once the maintenance window is completed, the USPS will work through the backlog of files.
During the maintenance window On Demand Tracking will work, however scan events created during the maintenance window will NOT be reported until the maintenance window is completed. The tracking functionality on the USPS website will have the same functionality as the On Demand Tracking during the maintenance window.
Start Time: Saturday, March 29 at 8:00 PM ET End Time: Sunday, March 30 at 3:00 AM ET
If you have any questions or concerns, please feel free to contact us.
Thank you, Client Support Tech Services
Posted Mar 26, 2025 - 13:23 EDT
This scheduled maintenance affected: eCommerce APIs (Shipping APIs) (Tracking).