FedEx Service Disruption Observed for Multiple Services.

Incident Report for Pitney Bowes

Resolved

FedEx have resolved the issue and all services are functional now.
Posted Mar 26, 2025 - 14:10 EDT

Investigating

Failures are being observed for FedEx carrier.
There is no ongoing issue with Pitney Bowes systems though the current carrier side errors might result in disruption of RateShipment and RateShipment.
Pitney Bowes Teams are actively working with FedEx and we will update as we make progress.
Posted Mar 26, 2025 - 12:54 EDT
This incident affected: Carriers (FedEX).