Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 02, 2025 - 00:00 EDT
Scheduled
As part of our ongoing effort to strengthen our Expedited Delivery Services infrastructure, we will be performing system maintenance in our Tracking Services PRODUCTION environment on Saturday, 2025-08-02 ,12:00 AM ET for 6 hours, you may see intermittent errors and there might be a delay in receiving tracking events during this window.
Description: We will be making modifications to the Tracking Services PRODUCTION environment which will improve overall performance and stability.
Start date/Time : 2024-08-02 12:00 AM ET End date/ Time: 2024-08-02 06:00 AM ET Duration: 6 Hours
If you experience any other issues during the maintenance window, please contact the Client Support Technical Services Team at ClientSupportTechServices@pb.com.
Posted Jul 24, 2025 - 15:09 EDT
This scheduled maintenance affected: eCommerce APIs (Shipping APIs) (Tracking).