FedEx Service Disruption Observed for RateShipment.
Incident Report for Pitney Bowes
Resolved
The issue has been resolved and Services are back to normal now.
Posted Oct 31, 2024 - 10:06 EDT
Investigating
Failures are being observed for RateShipment calls with FedEx carrier.
Teams are actively working with FedEx towards resolution.
Posted Oct 31, 2024 - 09:57 EDT
This incident affected: Carriers (FedEX).