Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 05, 2025 - 21:30 EST
Scheduled
As part of our ongoing effort to strengthen our Expedited Delivery Services infrastructure, we will be performing system maintenance in our Tracking Services PRODUCTION environment on Wednesday, 2025-03-05, 09:30 PM ET for 8 hours. There will be Intermittent errors for Tracking API.
Description:
We will be making modifications to the Tracking Services PRODUCTION environment which will improve overall performance and stability
Start date/Time: 2025-03-05 09:30 PM ET End date/ Time: 2025-03-06 05:30 AM ET
If you experience any other issues during the maintenance window, please contact the Client Support Technical Services Team at ClientSupportTechServices@pb.com.
Posted Mar 05, 2025 - 07:27 EST
This scheduled maintenance affected: eCommerce APIs (Shipping APIs) (Tracking).