Service Disruption observed for Shipping360 Platform for USA & Canada region.

Incident Report for Pitney Bowes

Resolved

The issue has been resolved and all services are back to normal.
Posted Jul 14, 2025 - 12:15 EDT

Update

We have mitigated the problem by switching over the traffic to secondary site and there should not be any more service disruption. We will keep posted here with latest updates.
Posted Jul 14, 2025 - 11:49 EDT

Identified

The issue has been identified and working towards resolution and SP360 Traffic has been failed over to PDX region to avoid any service disruption
Posted Jul 14, 2025 - 11:43 EDT

Investigating

We are currently experiencing technical issues with our Shipping360 Platform for USA & Canada region which is currently preventing users to access Shipping, Tracking, Lockers and Analytics Applications.
Our Outage Response Team is investigating to determine the full scope of the outage and will be working to restore the operation of the APIs. We will send you an update as quickly as possible.
Posted Jul 14, 2025 - 11:30 EDT
This incident affected: PitneyAnalytics (PitneyAnalytics USA, PitneyAnalytics Canada), Shipping (PitneyShip & PitneyShip Pro USA, PitneyShip Pro Canada, PitneyShip Enterprise USA, ShipAccel USA), and PitneyTrack & Lockers (PitneyTrack USA, PitneyTrack Canada, ParcelPoint USA, ParcelPoint Canada).