USPS Tracking - Incident - Initial Notification

Incident Report for Pitney Bowes

Resolved

USPS has experienced a technical issue on 08/04/2025 at approximately 5:15 am ET. At this time we see full functionality in the Tracking Services. We continue to closely monitor the situation.
Posted Aug 06, 2025 - 08:46 EDT

Investigating

USPS is currently experiencing an issue with their Tracking Services at approximately 5:15 am ET on 08/04/2025 that may prevent you from using the tracking services for USPS carriers.
You might not receive scan events in a timely manner and the USPS website might not be displaying scan events in a proper manner.
Once we have an update we will send you as quickly as possible.
Posted Aug 04, 2025 - 10:11 EDT
This incident affected: eCommerce APIs (Shipping APIs) (Tracking).