Intermittent Service Disruption observed for ParcelPoint for USA region.

Incident Report for Pitney Bowes

Resolved

Issue has been resolved and all services are functional now .
Posted Sep 03, 2025 - 06:09 EDT

Investigating

We are currently experiencing technical issues with our ParcelPoint for USA region.
Our Outage Response Team is investigating to determine the full scope of the outage and will be working to restore the operation of the APIs. We will send you an update as quickly as possible.
Posted Sep 02, 2025 - 14:59 EDT
This incident affected: PitneyTrack & Lockers (ParcelPoint USA).