USPS Tracking - Incident - Initial Notification

Incident Report for Pitney Bowes

Resolved

Following up on our earlier communication regarding the USPS tracking system issues, we wanted to inform you that the issue has now been resolved. However, there is currently a backlog in processing, and the following impacts are still being observed:

- Processing of inbound Shipping Services manifests, Shipping Partner event files, and scan events sent is ongoing but delayed.
- USPS Tracking® is available, though the data displayed may be stale or not up to date.

We are continuing to monitor the situation closely and will provide further updates as needed.
Posted Sep 09, 2025 - 13:51 EDT

Investigating

USPS is currently experiencing an issue with their Tracking Services at approximately 12:20 PM ET on 9/09/25 that may prevent you from using the tracking services for USPS carriers.
You might not receive scan events in a timely manner and the USPS website might not be displaying scan events in a proper manner.
Once we have an update we will send you as quickly as possible.
Posted Sep 09, 2025 - 12:47 EDT
This incident affected: eCommerce APIs (Shipping APIs) (Tracking).