UPS Service Disruption Observed for Multiple Services.

Incident Report for Pitney Bowes

Resolved

UPS have resolved the issue and all services are functional now.
Posted Mar 18, 2025 - 13:27 EDT

Investigating

Failures are being observed for UPS carrier.
There is no ongoing issue with Pitney Bowes systems though the current carrier side errors might result in disruption of v1/information/shipments/carrier-facility.
Pitney Bowes Teams are actively working with UPS and we will update as we make progress.
Posted Mar 18, 2025 - 13:18 EDT
This incident affected: Carriers (UPS).