FedEx Service Disruption Observed for RateShipment.
Incident Report for Pitney Bowes
Resolved
FedEx have resolved the issue and all services are functional now.
Posted Jan 28, 2025 - 14:57 EST
Investigating
Failures are being observed for FedEx carrier.
There is no ongoing issue with Pitney Bowes systems though the current carrier side errors might result in disruption of RateShipment.
Pitney Bowes Teams are actively working with FedEx and we will update as we make progress.
Posted Jan 28, 2025 - 14:49 EST
This incident affected: Carriers (FedEX).