Intermittent Service Disruption observed for Shipping360 Platform for USA region.

Incident Report for Pitney Bowes

Resolved

The issue has been resolved and all services are back to normal.
Posted Aug 15, 2026 - 06:08 EDT

Investigating

We are currently experiencing a service disruption affecting Cost Account management. Users are unable to add or remove Cost Accounting data at this time. Existing Cost Accounts are not impacted and continue to function normally. Postage meters and mailing devices are unable to sync Cost Account lists.
Our team is actively investigating and working toward a resolution. We will provide updates as progress is made.
Posted Aug 14, 2026 - 23:47 EDT
This incident affected: Shipping (PitneyShip & PitneyShip Pro USA, PitneyShip Enterprise USA).