USPS Tracking Incident

Incident Report for Pitney Bowes

Resolved

USPS Final update March 13 2026 03:00 PM

Processing backlogs have caught up.
USPS Tracking® is available and current.
Customer extracts are current.
Posted Mar 13, 2026 - 15:44 EDT

Investigating

USPS is currently experiencing an issue with their Tracking Services from approximately 10:00 AM ET on 03/13/26 that may prevent you from using the tracking services for USPS carriers.

Processing of inbound Shipping Services manifest, Shipping Partner event files, and scan events sent to PTR continue to be received but are experiencing a delay in processing.

USPS Tracking® is currently available but data displayed may be stale. Customer extracts are delayed.

Webhooks data provided is impacted by delays.

Once we have an update we will send you as quickly as possible.
Posted Mar 13, 2026 - 11:03 EDT
This incident affected: eCommerce APIs (Shipping APIs) (Tracking).