Performance issue observed for SendPro Enterprise for USA region.

Incident Report for Pitney Bowes

Resolved

The issue has been resolved, and we've observed improved performance. The application is now functioning as expected.
Posted May 20, 2025 - 16:52 EDT

Investigating

Performance issue are being observed for SendPro Enterprise for USA region.
Pitney Bowes Technical Teams are actively working on this and we will update as we make progress.
Posted May 20, 2025 - 13:26 EDT
This incident affected: SendPro Enterprise.