Intermittent Service Disruption observed for Shipping for USA region.

Incident Report for Pitney Bowes

Resolved

This incident has been resolved.
Posted May 15, 2025 - 14:36 EDT

Update

We have identified issue and working towards resolution.
Posted May 15, 2025 - 14:15 EDT

Investigating

We are currently experiencing technical issues with our Shipping for USA region.
Our Outage Response Team is investigating to determine the full scope of the outage and will be working to restore the operation of the APIs. We will send you an update as quickly as possible.
Posted May 15, 2025 - 14:06 EDT
This incident affected: Shipping (PitneyShip & PitneyShip Pro USA, PitneyShip Enterprise USA) and SendPro Enterprise.