Service Disruption observed for Shipping360 Platform for USA, Canada, Europe, UK & ANZ region.

Incident Report for Pitney Bowes

Resolved

The issue has been resolved and all services are back to normal.
Posted May 11, 2026 - 15:17 EDT

Investigating

Login Failures are being observed for Shipping360 Platform for USA, Canada, Europe, UK & ANZ region which is currently preventing users to access Shipping, Tracking, Lockers and Analytics Applications.
Pitney Bowes Technical Teams are actively working on this and we will update as we make progress.
Posted May 11, 2026 - 14:16 EDT
This incident affected: PitneyAnalytics (PitneyAnalytics USA, PitneyAnalytics Canada), Shipping (PitneyShip & PitneyShip Pro USA, PitneyShip Pro Canada, PitneyShip & PitneyShip Pro Europe, PitneyShip Pro UK, PitneyShip Enterprise USA, PitneyShip Enterprise Europe, ShipAccel USA), and PitneyTrack & Lockers (PitneyTrack USA, PitneyTrack Canada, PitneyTrack Europe, PitneyTrack UK, PitneyTrack ANZ, ParcelPoint USA, ParcelPoint Canada).