Service Disruption for CreateShipment

Incident Report for Pitney Bowes

Resolved

The issue is resolved, and services are back to normal now.
Posted Jun 11, 2024 - 08:00 EDT

Update

We are continuing to investigate this issue.
Posted Jun 11, 2024 - 07:35 EDT

Investigating

We are currently investigating the issue.
Posted Jun 11, 2024 - 07:24 EDT
This incident affected: Shipping (PitneyShip & PitneyShip Pro USA, PitneyShip Pro Canada, PitneyShip & PitneyShip Pro Europe, PitneyShip Pro UK, PitneyShip Enterprise USA).