UPS Service Disruption Observed for RateShipment.
Incident Report for Pitney Bowes
Resolved
The issue has been resolved and Services are back to normal now.
Posted Nov 12, 2024 - 17:12 EST
Investigating
Failures are being observed for RateShipment calls with UPS carrier.
Teams are actively working with UPS towards resolution.
Posted Nov 12, 2024 - 16:52 EST
This incident affected: Carriers (UPS).