Canada Post Service Disruption Observed for RateShipment.

Incident Report for Pitney Bowes

Resolved

Canada Post have resolved the issue and all services are functional now.
Posted Mar 19, 2025 - 19:46 EDT

Investigating

Failures are being observed for Canada Post carrier.
There is no ongoing issue with Pitney Bowes systems though the current carrier side errors might result in disruption of RateShipment.
Pitney Bowes Teams are actively working with Canada Post and we will update as we make progress.
Posted Mar 19, 2025 - 19:40 EDT
This incident affected: Carriers (Canada Post).