Service Disruption observed for Shipping for USA, Canada, Europe & UK region.

Incident Report for Pitney Bowes

Resolved

The issue has been resolved and all services are back to normal.
Posted Jul 15, 2025 - 11:46 EDT

Investigating

Failures are being observed for Shipping for USA, Canada, Europe & UK region.
Pitney Bowes Technical Teams are actively working on this and we will update as we make progress.
Posted Jul 15, 2025 - 11:34 EDT
This incident affected: Shipping (PitneyShip & PitneyShip Pro USA, PitneyShip Pro Canada, PitneyShip & PitneyShip Pro Europe, PitneyShip Pro UK, PitneyShip Enterprise USA, PitneyShip Enterprise Europe, ShipAccel USA).