FedEx Service Disruption Observed for RateShipment.

Incident Report for Pitney Bowes

Resolved

The issue has been resolved and Services are back to normal now.
Posted Oct 30, 2024 - 18:50 EDT

Investigating

Failures are being observed for RateShipment calls with FedEx carrier.
Teams are actively working with FedEx towards resolution.
Posted Oct 30, 2024 - 18:40 EDT
This incident affected: Carriers (FedEX).