Service Disruption observed for Shipping360 Platform & Shipping360 APIs for USA region.

Incident Report for Pitney Bowes

Resolved

The issue has been resolved and all services are back to normal.
Posted Mar 10, 2025 - 21:11 EDT

Investigating

We are currently experiencing technical issues with our Shipping360 Platform & Shipping360 APIs for USA region which is currently preventing users to access Shipping, Tracking, Lockers and Analytics Applications.
Our Outage Response Team is investigating to determine the full scope of the outage and will be working to restore the operation of the APIs. We will send you an update as quickly as possible.
Posted Mar 10, 2025 - 20:40 EDT
This incident affected: Shipping360 APIs (Address, Carrier Account, Manifest, Multipiece APIs, Payment, Pickups, Print, Shipment By Rate Shop, Tracking, Batch, Cost Account Management, Location).