USPS Service Disruption Observed for RateShipment.
Incident Report for Pitney Bowes
Resolved
The issue has resolved, and all services are functional now.
Posted Jan 30, 2025 - 10:02 EST
Update
We are continuing to investigate this issue.
Posted Jan 30, 2025 - 09:53 EST
Investigating
Failures are being observed for USPS carrier.
There is no ongoing issue with Pitney Bowes systems though the current carrier side errors might result in disruption of RateShipment.
Pitney Bowes Teams are actively working with USPS and we will update as we make progress.
Posted Jan 30, 2025 - 07:49 EST
This incident affected: Shipping (PitneyShip & PitneyShip Pro USA, PitneyShip Enterprise USA, ShipAccel USA), Shipping360 APIs (Shipment), and Carriers (USPS).