Expedited Delivery Services - Incident - Initial Notification

Incident Report for Pitney Bowes

Resolved

This incident has been resolved.
Posted Jun 28, 2026 - 13:23 EDT

Monitoring

Our Emergency Response Team contacted USPS and confirmed that the USPS Ship APIs are currently undergoing scheduled maintenance from 05:00 AM CT to 12:00 PM CT. During this maintenance window, some API services may experience intermittent issues.

We are continuing to monitor the situation closely and will provide further updates as soon as additional information becomes available or once normal service has been restored.
Posted Jun 28, 2026 - 07:14 EDT

Investigating

We are currently experiencing technical issues from USPS API's in PRODUCTION environment that may prevent you from using some features of the Expedited Delivery Services.

Our Emergency Response Team is investigating with USPS to determine the full scope of the outage and will be working to restore the operation of the APIs. We will send you an update as quickly as possible.
Posted Jun 28, 2026 - 06:55 EDT
This incident affected: eCommerce APIs (Shipping APIs) (Create Label, Get Rates).