Service disruption impacting shipping
Incident Report for Pitney Bowes
Resolved
This incident has been resolved.
Posted Aug 28, 2024 - 07:01 EDT
Investigating
we are currently investigating
Posted Aug 28, 2024 - 06:47 EDT
This incident affected: Shipping (PitneyShip & PitneyShip Pro USA).