SP360 application is experiencing slowness on the login page

Incident Report for Pitney Bowes

Resolved

The team has identified and fixed the issue. The application is now working as expected.
Posted Feb 11, 2026 - 02:39 EST

Investigating

SP360 application is experiencing slowness on the login page. Teams are actively working on the issue.
Posted Feb 11, 2026 - 02:24 EST
This incident affected: PitneyAnalytics (PitneyAnalytics USA), Shipping (PitneyShip & PitneyShip Pro USA, ShipAccel USA), PitneyTrack & Lockers (PitneyTrack USA), and FedRAMP (PitneyShip & PitneyShip Pro).