Device Hub Down impacting shipping functionality

Incident Report for Pitney Bowes

Resolved

Issue has been resolved, DeviceHub is operational now
Posted Aug 10, 2024 - 11:35 EDT

Investigating

We are currently investigating this issue.
Posted Aug 10, 2024 - 11:33 EDT
This incident affected: FedRAMP (PitneyShip & PitneyShip Pro).