SPE is having issues impacting all the customers to use the application.
Incident Report for Pitney Bowes
Resolved
The issue has been resolved and the application is back to normal.
Posted Jun 24, 2024 - 06:00 EDT
Investigating
We have observed an issue with the SPE application where users are not able to use the application.
Posted Jun 24, 2024 - 04:42 EDT
This incident affected: SendPro Enterprise.