Login Service Disruption Impacting SendPro Enterprise Clients

Incident Report for Pitney Bowes

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 09:14 EDT

Investigating

Login Service Disruption for SPE clients due to unavailability of Community Management Console (CMC) portal, currently we are investigating the issue on Priority.
Posted Aug 05, 2025 - 07:33 EDT
This incident affected: SendPro Enterprise.