Intermittent SP360 Login Issues observed

Incident Report for Pitney Bowes

Resolved

This issue has been resolved and all functionalities are restored successfully.
Posted Nov 24, 2025 - 13:44 EST

Update

We are currently investigating intermittent login issues impacting login on SP360. Our team is actively working to identify the root cause and restore full functionality. We will provide updates as soon as more information becomes available.
Posted Nov 24, 2025 - 13:05 EST

Investigating

We are currently investigating issue and will update you
Posted Nov 24, 2025 - 12:23 EST
This incident affected: Shipping (PitneyShip & PitneyShip Pro USA, PitneyShip Pro Canada, PitneyShip & PitneyShip Pro Europe, PitneyShip Pro UK, PitneyShip Enterprise USA, PitneyShip Enterprise Europe, ShipAccel USA) and PitneyTrack & Lockers (PitneyTrack USA, PitneyTrack Canada, PitneyTrack Europe, PitneyTrack UK, PitneyTrack ANZ, ParcelPoint USA, ParcelPoint Canada).