SPE Users are not able to login

Incident Report for Pitney Bowes

Resolved

Issue has been resolved.
Posted May 16, 2024 - 11:43 EDT

Investigating

The issue is under investigation.
Posted May 16, 2024 - 10:45 EDT
This incident affected: SendPro Enterprise.