Service Disruption observed for ShipAccel Application for USA region

Incident Report for Pitney Bowes

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 13:27 EDT

Investigating

We are currently experiencing technical issues with our ShipAccel for USA region.
Our Outage Response Team is investigating to determine the full scope of the outage and will be working to restore the operation of the APIs. We will send you an update as quickly as possible.
Posted Apr 15, 2025 - 12:59 EDT
This incident affected: Shipping (ShipAccel USA).